Agrégation interne de mathématiques
Outils logiciels et calculatrices

Utilisation de calculatrices

  • Les calculatrices ne sont pas autorisées pour les épreuves écrites.
  • L'utilisation de calculatrices personnelles est interdite pour l'épreuve d'exemples et exercices. Un émulateur de calculatrice est fourni avec les logiciels mis à disposition.
  • Lors de l'épreuve d'exposé (ou leçon), tout candidat qui le souhaite peut demander à utiliser une calculatrice personnelle. Il doit alors en faire la demande au cours de sa préparation. La présidence du jury se prononce en fonction du sujet traité et après examen de la calculatrice du candidat; l'utilisation effective de cette calculatrice est alors attendue pendant l'interrogation.
  • Le jury ne met pas de calculatrices à la disposition des candidats.

Utilisation de logiciels

Lors de l'épreuve orale d'exemples et exercices, chaque candidat a accès à un ordinateur muni de logiciels dont la liste est précisée dans le B.O.E.N. spécial n°1 du 27 janvier 2011 (voir ici). La fin du programme mentionné stipule :

La seconde épreuve orale, dite d'exemples et exercices, repose sur les programmes détaillés dans les parties A et B. Au cours de cette épreuve, le candidat présentera un choix d'exemples ou d'exercices dont l'un pourra intégrer soit une activité de programmation simple soit faire appel à un outil logiciel. Il est précisé que le matériel informatique mis à la disposition des candidats pendant le temps de préparation fonctionne sous le système Linux, et comportera les logiciels de la liste précisée ci-dessous. Les versions des logiciels ne sont données qu'à titre indicatif et sont susceptibles d'être modifiées.

Le système installé sur les machines (clefagreg) peut être téléchargé sur le site de clefagreg.

Langages et environnements de programmation :

  • Free Pascal version 2.6, environnement de programmation FP ou Lazarus
  • Python version 3.4, environnement de programmation Pyzo
Logiciels :
  • CaRMetal version 2.9.8
  • Geogebra version 4.0
  • Geoplan / Geospace
  • Maxima version 5.27
  • OpenOffice.org ou Libreoffice version 3.5.4
  • Scilab version 5.5 (ou 5.3 en cas de problèmes)
  • Xcas version 1.2.2 (ou 1.1.3-5 en cas de problèmes)
Avertissements :
  • En raisons de diverses incompatibilités, les émulateurs Classpad Manager, TI-Nspire CAS et les programmes Cabri ne seront plus fournis.
  • Maple n'est plus fourni depuis la session 2015. À titre experimental SAGE sera testé pour la session 2015 (version 7 ou 6.5 en cas de problèmes).
  • Un programme émulant une calculatrice scientifique sera fourni (en principe, galculator).